Remotix

Fast and powerful remote management client. Install Remotix on your device to connect to remote machines.

Remotix for Windows

Current version: 6.3.1 (10021). Requires Windows 7 or later and DirectX 9 capable graphics card.

Remotix for macOS

Current version: 6.3 (21762). Requires macOS 10.11 or later.

Remotix for Linux (AppImage)

Current version: 6.4.1 (868). Works on openSUSE 8; Debian 9, 10; Ubuntu 18.0-20.10; RHEL 8; CentOS 8; Fedora 31-33; SLES 15sp2; ALT; Astra Oryol; Mint 20; Manjaro 20.

Remotix for Linux (.rpm package, x86_64)

Works on RHEL 8.3; Centos 8; Fedora 31-33.

Remotix for iOS

Current version: 8.4.

Remotix for Android

Current version: 8.1.8.

Remotix Agent

Remotix Agent provides advanced capabilities for remote management. Install it on your remote device to be able to manage it remotely via Remotix or Remotix Hub and fine-tune the permissions.

Agent for Windows

Current version: 1.5.11 (13740). Requires Windows 7 or Windows Server 2008R2 or later.

Agent for macOS

Current version: 1.5.8 (22338). Requires macOS 10.9 or later.

Agent for RHEL/Fedora (.rpm package, x86_64)

Current version: 1.5.7 (1408). Compatibility with Fedora 30, Red Hat Enterprise Linux 8.0 and Red Hat Enterprise Linux 8.1 confirmed.

Agent for Ubuntu/Debian Linux (.deb package, amd64)

Current version: 1.5.7 (1408). Compatibility with Debian 9 (Stretch), Debian 10 (Buster), Ubuntu 18.04 LTS (Bionic Beaver) and Ubuntu 19.04 (Disco Dingo) confirmed.

Agent for Generic Linux (.tar.gz, x86_64)

Current version: 1.5.7 (1408). Compatibility with on CentOS 7 and OpenSUSE 15.1 (Leap) confirmed.

Agent for Raspberry Pi (.deb package, armhf)

Current version: 1.5.7 (1408). Works on Raspberry Pi 3 and later under Raspbian Buster.

Remotix Quick Connect

A tiny portable application with zero configuration. Run it on a computer that you want to observe or control remotely.

QC for Windows

Current version: 1.5.5 (4688). Requires Windows 7 or Windows Server 2008R2 or later.

QC for macOS

Current version: 1.5.4 (13252). Requires macOS 10.9 or later.